Jump to content

Laptop power problems


Ocho
 Share

Recommended Posts

I've got an HP Pavillion laptop and I've got some problems with my power.

 

My original power supply was knackered, so I bought a cheaper version from ebay and it worked ok for a month, but now this happens..........

 

If the laptop is switched off and power plugged in, the battery charges (indicated by the charging light)

If the laptop is switched on and power plugged in, the charging light goes off, but the blue light where the AC charger is plugged in is lit up

If you take the battery out and switch the laptop on, it doesn't come on.

 

I thought you could work the laptop without the battery, so the 3rd part suggests that there's something wrong with the actual laptop.

 

Is it a dodgy power supply?  I've noticed that when the charger is plugged in, you can 'waggle' the connection - so is there something wrong with the connection inside?

 

Has anybody got any solutions? (except for buying a new one!)

Link to post
Share on other sites

I've got an HP Pavillion laptop and I've got some problems with my power.

 

My original power supply was knackered, so I bought a cheaper version from ebay and it worked ok for a month, but now this happens..........

 

If the laptop is switched off and power plugged in, the battery charges (indicated by the charging light)

If the laptop is switched on and power plugged in, the charging light goes off, but the blue light where the AC charger is plugged in is lit up

If you take the battery out and switch the laptop on, it doesn't come on.

 

I thought you could work the laptop without the battery, so the 3rd part suggests that there's something wrong with the actual laptop.

 

Is it a dodgy power supply?  I've noticed that when the charger is plugged in, you can 'waggle' the connection - so is there something wrong with the connection inside?

 

Has anybody got any solutions? (except for buying a new one!)

 

Think I know whats wrong, as I had a similar problem, though self inflicted. Laptop fell off my bed and landed on its side with the charger plugged in, fucked the chargers casing up something rotten, but it still worked. The laptop, however, did not charge, had it fixed recently, guy who did it for me said the bit on the motherboard that controls charging up had come loose, so he just soldered it and it was sorted.  However, it be that its fucked and you need a new motherboard, which can be pricy, get someone to have a look at it, but if you don't want to spend loads of money on it, I'd suggest just using it with the charger plugged in all the time.

Link to post
Share on other sites

Laptop fell off my bed and landed on its side with the charger plugged in

 

Spot on.  That's exactly what happened.

 

However it doesn't work with the charger plugged in - it says plugged in, not charging and switches off after a while.

 

Thanks for the info, you've been very helpful.

Link to post
Share on other sites

Laptop fell off my bed and landed on its side with the charger plugged in

 

Spot on.  That's exactly what happened.

 

However it doesn't work with the charger plugged in - it says plugged in, not charging and switches off after a while.

 

Thanks for the info, you've been very helpful.

 

Definitely sounds like motherboard has a problem then, not the entire thing, just the bit that deals with charging. You should be able to get it sorted. Happy to help. :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...