Jump to content

Windows 7 & Belkin Router


Recommended Posts

Dunno if anyone has come across something like this, but since upgrading to Windows 7, my router will not connect at all to my PC. It's fine with the xbox, iphone, and a laptop (running vista), but will just flat out not connect to the PC. I've tried using wireless, which says it connects, but it isn't getting a ip address. When I try and connect with the ethernet cable, it just seems to cycle between disconnected and unidentified. I'm completely stumped. I know the router itself is fine, and I can actually use an old shitty router to connect to the PC, so I know that's fine. Tried updating the drivers and flashing the firmware, but no use. Any suggestions?  ???

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...