Jump to content

Help needed with Samsung Galaxy S10+ phone


GM
 Share

Recommended Posts

Thinking I was getting a bargain, I bought a refurbished SIM free Samsung Galaxy S10+ from a third party vendor on Amazon back in October and I've been using it with my giffgaff SIM ever since. So far, so good. However, when it arrived, it had some Telstar (Australian telecoms company?) software on it, which I deleted and didn't think anything further about it.

 

However, I've more recently noticed that this handset seems to have recurrent problems with slow connections to our home internet/WiFi, where it sort of 'hangs' or fails to load up pages on the browser or even on certain apps like Twitter and Facebook. When that happens I have to turn off the WiFi, refresh and then it works fine on 4G. But it's so getting a bit annoying. Can help me diagnose/fix this issue? Is it possibly something to do with the fact this handset's former life was on a different continent?

 

The local high street Samsung shop unable to help me at all, so I was wondering if anyone out there can help out even point me in the direction of another advice source/chat room where IT savvy geeks might be able to help diagnose/fix this issue?

Link to post
Share on other sites

I've had this problem with my last two phones. A Huawei P20 Pro and now the Pixel 4 XL. Both unlocked and from UK suppliers so you can rule out it being anything to do with the Telstar thing. It's annoying as fuck. I've tried some fixes online but they haven't worked.

 

Hopefully someone knows.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...